$re = '/(\w*)\s*\([(\w*),]*\)/';
$str = 'f1 (11,22,33)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);