# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<!--([\s\S]*?)-->"
test_str = ("</ul>\n"
"<p>\n"
" Evaluation<!--[if gte mso 9]><xml>\n"
"<o:OfficeDocumentSettings>\n"
"<o:AllowPNG />\n"
"<o:TargetScreenSize>1024x768</o:TargetScreenSize>\n"
"</o:OfficeDocumentSettings>\n"
"</xml><![endif]--><!--[if gte mso 9]><xml>\n"
"<w:WordDocument>\n"
"<w:View>Normal</w:View>\n"
"<w:Zoom>0</w:Zoom>\n"
"<w:HyphenationZone>21</w:HyphenationZone>\n"
"<w:PunctuationKerning />\n"
"<w:ValidateAgainstSchemas />\n"
"<w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid>\n"
"<w:IgnoreMixedContent>false</w:IgnoreMixedContent>\n"
"<w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText>\n"
"<w:Compatibility>\n"
"<w:BreakWrappedTables />\n"
"<w:SnapToGridInCell />\n"
"<w:WrapTextWithPunct />\n"
"<w:UseAsianBreakRules />\n"
"<w:DontGrowAutofit />\n"
"</w:Compatibility>\n"
"</w:WordDocument>\n"
"</xml><![endif]--><!--[if gte mso 9]><xml>\n"
"<w:LatentStyles DefLockedState=\"false\" LatentStyleCount=\"156\">\n"
"</w:LatentStyles>\n"
"</xml><![endif]--><!--[if gte mso 10]>\n"
"<style>\n"
"/* Style Definitions */\n"
"table.MsoNormalTable\n"
"{mso-style-name:\"Normale Tabelle\";\n"
"mso-tstyle-rowband-size:0;\n"
"mso-tstyle-colband-size:0;\n"
"mso-style-noshow:yes;\n"
"mso-style-parent:\"\";\n"
"mso-padding-alt:0cm 5.4pt 0cm 5.4pt;\n"
"mso-para-margin:0cm;\n"
"mso-para-margin-bottom:.0001pt;\n"
"mso-pagination:widow-orphan;\n"
"font-size:10.0pt;\n"
"font-family:\"Times New Roman\";\n"
"mso-ansi-language:#0400;\n"
"mso-fareast-language:#0400;\n"
"mso-bidi-language:#0400;}\n"
"</style>\n"
"<![endif]--></p>\n"
"<ul>\n"
" <li>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.