import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=\\.de\\/type1\\/)\\d+|(?<=\\.de\\/)(?!type1)[^\\.]+)";
final String string = "www.test.de/type1/12345/this-is-a-title.html\n"
+ "www.test.de/category/another-title-oh-yes.html";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}