$re = '/((?<=\.de\/type1\/)\d+|(?<=\.de\/)(?!type1)[^\.]+)/';
$str = 'www.test.de/type1/12345/this-is-a-title.html
www.test.de/category/another-title-oh-yes.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);