const regex = /^ # start of line
(?=(?:.*[A-Z]){2,}) # 2 upper case letters
(?=(?:.*[a-z]){2,}) # 2 lower case letters
(?=(?:.*\d){2,}) # 2 digits
(?=(?:.*[!@#$%^&*()\-_=+{};:,<.>]){2,}) # 2 special characters
(.{8,}) # length 8 or more
$
/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^ # start of line
(?=(?:.*[A-Z]){2,}) # 2 upper case letters
(?=(?:.*[a-z]){2,}) # 2 lower case letters
(?=(?:.*\\d){2,}) # 2 digits
(?=(?:.*[!@#$%^&*()\\-_=+{};:,<.>]){2,}) # 2 special characters
(.{8,}) # length 8 or more
$
', 'gm')
const str = `Valid:
ABab12!!
ZZzz11#####
PAssword12!!
PassWord12!!
AA aa 12 ##
A1#a2Z3z5%
Not Valid:
AAaa1234
Password12!!
Abab12!!
ZZzz11#
password12!!
Password12!!
AAAa12##
A1 a2Z3z5%
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}