package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:\d+(?:\.\d*)?)|(?:\.\d+))$`)
var str = `1.10000
5.
678.6
.56
.
2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}