$re = '/^((?:\d+(?:\.\d*)?)|(?:\.\d+))$/m';
$str = '1.10000
5.
678.6
.56
.
2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);