package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)foobar`)
var str = `foo
foobar
bar
foobar
biff
foobar
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}