$re = '/(&)(\'.$Key.\')([^0-9a-zA-Z_])/';
$str = '<?php
// Сравниваем Куки Ñ Ð´Ð°Ð½Ð½Ñ‹Ð¼Ð¸
if ($_COOKIE[\'login\'] == $admin_login AND $_COOKIE[\'password\'] == md5($admin_pass))
{
If (isset($_POST[\'submit\'])){
$date=explode(".", date("d.m.Y"));
switch ($date[1]){
case 1: $m=\'ÑнварÑ\'; break;
case 2: $m=\'февралÑ\'; break;
case 3: $m=\'марта\'; break;
case 4: $m=\'апрелÑ\'; break;
case 5: $m=\'маÑ\'; break;
case 6: $m=\'июнÑ\'; break;
case 7: $m=\'июлÑ\'; break;
case 8: $m=\'авгуÑта\'; break;
case 9: $m=\'ÑентÑбрÑ\'; break;
case 10: $m=\'октÑбрÑ\'; break;
case 11: $m=\'ноÑбрÑ\'; break;
case 12: $m=\'декабрÑ\'; break;
}
$createdata = $date[0].\' \'.$m.\', \'.$date[2];
$useradd = \'Admin\';
$name = $_POST[\'amess\'];
$useradd = $_POST[\'useradd\'];
$text = $_POST[\'mess\'];
$textkrat = $_POST[\'opisan\'];
$title = $_POST[\'title\'];
$description = $_POST[\'description\'];
$keyword = $_POST[\'keywords\'];
$url = $_POST[\'amessurl\'];
$tegs = $_POST[\'tegs\'];
?>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);