import Foundation
let pattern = #"(&)('.$Key.')([^0-9a-zA-Z_])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<?php
// Сравниваем Куки Ñ Ð´Ð°Ð½Ð½Ñ‹Ð¼Ð¸
if ($_COOKIE['login'] == $admin_login AND $_COOKIE['password'] == md5($admin_pass))
{
If (isset($_POST['submit'])){
$date=explode(".", date("d.m.Y"));
switch ($date[1]){
case 1: $m='ÑнварÑ'; break;
case 2: $m='февралÑ'; break;
case 3: $m='марта'; break;
case 4: $m='апрелÑ'; break;
case 5: $m='маÑ'; break;
case 6: $m='июнÑ'; break;
case 7: $m='июлÑ'; break;
case 8: $m='авгуÑта'; break;
case 9: $m='ÑентÑбрÑ'; break;
case 10: $m='октÑбрÑ'; break;
case 11: $m='ноÑбрÑ'; break;
case 12: $m='декабрÑ'; break;
}
$createdata = $date[0].' '.$m.', '.$date[2];
$useradd = 'Admin';
$name = $_POST['amess'];
$useradd = $_POST['useradd'];
$text = $_POST['mess'];
$textkrat = $_POST['opisan'];
$title = $_POST['title'];
$description = $_POST['description'];
$keyword = $_POST['keywords'];
$url = $_POST['amessurl'];
$tegs = $_POST['tegs'];
?>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}