import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/?(\\d)";
final String string = "<?xml version=\"1.0\"?>\n"
+ "<data>\n"
+ " <client_name>Awesome Client</client_name>\n"
+ " <account_number/>\n"
+ " <date_created>02/12/2016</date_created>\n"
+ " <form_number>4126</form_number>\n"
+ " <customer_po/>\n"
+ " <terms_name>Credit Card</terms_name>\n"
+ " <date_shipped>12/31/1969</date_shipped>\n"
+ " <billing_contact_email/>\n"
+ " <billing_contact_address_line_1/>\n"
+ " <billing_contact_address_line_2/>\n"
+ " <billing_contact_address_line_3/>\n"
+ " <billing_contact_address_line_4/>\n"
+ " <billing_contact_address_city/>\n"
+ " <billing_contact_address_state>British Columbia</billing_contact_address_state>\n"
+ " <billing_contact_address_postal/>\n"
+ " <billing_contact_address_country>Canada</billing_contact_address_country>\n"
+ " <shipping_contact_address_line_1/>\n"
+ " <shipping_contact_address_line_2/>\n"
+ " <shipping_contact_address_line_3/>\n"
+ " <shipping_contact_address_line_4/>\n"
+ " <shipping_contact_address_city/>\n"
+ " <shipping_contact_address_state>British Columbia</shipping_contact_address_state>\n"
+ " <shipping_contact_address_postal/>\n"
+ " <shipping_contact_address_country>Canada</shipping_contact_address_country>\n"
+ " <billing_contact_first_name>another</billing_contact_first_name>\n"
+ " <billing_contact_last_name>client</billing_contact_last_name>\n"
+ " <client_rep_full_name>Rob Montebelli</client_rep_full_name>\n"
+ " <order_rep_full_name>Mark Graham</order_rep_full_name>\n"
+ " <job_name>77777</job_name>\n"
+ " <job_number>2620</job_number>\n"
+ " <event_type>Donor Gift</event_type>\n"
+ " <due_date>02/12/2016</due_date>\n"
+ " <shipping_method/>\n"
+ " <currency>CAD</currency>\n"
+ " <total_taxes>0.00</total_taxes>\n"
+ " <total_subtotal>1,760.16</total_subtotal>\n"
+ " <total>1,760.16</total>\n"
+ " <items>\n"
+ " <item0>\n"
+ " <taxes>\n"
+ " <0>E</0>\n"
+ " </taxes>\n"
+ " <title>1889-24</title>\n"
+ " <quantity>6</quantity>\n"
+ " <description>Carhartt (R) Signature Utility Duffel; TBD TBD</description>\n"
+ " <unit_price>159.32</unit_price>\n"
+ " </item0>\n"
+ " <item1>\n"
+ " <taxes>\n"
+ " <0>E</0>\n"
+ " </taxes>\n"
+ " <title>0022-56</title>\n"
+ " <quantity>12</quantity>\n"
+ " <description>Zoom (TM) DayTripper Sling Compu-Messenger; TBD TBD</description>\n"
+ " <unit_price>67.02</unit_price>\n"
+ " </item1>\n"
+ " </items>\n"
+ "</data>";
final String subst = "<number$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}