# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\/?(\d)"
test_str = ("<?xml version=\"1.0\"?>\n"
"<data>\n"
" <client_name>Awesome Client</client_name>\n"
" <account_number/>\n"
" <date_created>02/12/2016</date_created>\n"
" <form_number>4126</form_number>\n"
" <customer_po/>\n"
" <terms_name>Credit Card</terms_name>\n"
" <date_shipped>12/31/1969</date_shipped>\n"
" <billing_contact_email/>\n"
" <billing_contact_address_line_1/>\n"
" <billing_contact_address_line_2/>\n"
" <billing_contact_address_line_3/>\n"
" <billing_contact_address_line_4/>\n"
" <billing_contact_address_city/>\n"
" <billing_contact_address_state>British Columbia</billing_contact_address_state>\n"
" <billing_contact_address_postal/>\n"
" <billing_contact_address_country>Canada</billing_contact_address_country>\n"
" <shipping_contact_address_line_1/>\n"
" <shipping_contact_address_line_2/>\n"
" <shipping_contact_address_line_3/>\n"
" <shipping_contact_address_line_4/>\n"
" <shipping_contact_address_city/>\n"
" <shipping_contact_address_state>British Columbia</shipping_contact_address_state>\n"
" <shipping_contact_address_postal/>\n"
" <shipping_contact_address_country>Canada</shipping_contact_address_country>\n"
" <billing_contact_first_name>another</billing_contact_first_name>\n"
" <billing_contact_last_name>client</billing_contact_last_name>\n"
" <client_rep_full_name>Rob Montebelli</client_rep_full_name>\n"
" <order_rep_full_name>Mark Graham</order_rep_full_name>\n"
" <job_name>77777</job_name>\n"
" <job_number>2620</job_number>\n"
" <event_type>Donor Gift</event_type>\n"
" <due_date>02/12/2016</due_date>\n"
" <shipping_method/>\n"
" <currency>CAD</currency>\n"
" <total_taxes>0.00</total_taxes>\n"
" <total_subtotal>1,760.16</total_subtotal>\n"
" <total>1,760.16</total>\n"
" <items>\n"
" <item0>\n"
" <taxes>\n"
" <0>E</0>\n"
" </taxes>\n"
" <title>1889-24</title>\n"
" <quantity>6</quantity>\n"
" <description>Carhartt (R) Signature Utility Duffel; TBD TBD</description>\n"
" <unit_price>159.32</unit_price>\n"
" </item0>\n"
" <item1>\n"
" <taxes>\n"
" <0>E</0>\n"
" </taxes>\n"
" <title>0022-56</title>\n"
" <quantity>12</quantity>\n"
" <description>Zoom (TM) DayTripper Sling Compu-Messenger; TBD TBD</description>\n"
" <unit_price>67.02</unit_price>\n"
" </item1>\n"
" </items>\n"
"</data>")
subst = "<number$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.