import re
regex = re.compile(r"^(?:(?:(?:0?[13578]|1[02])(\/|-|\.)31)\1|(?:(?:0?[1,3-9]|1[0-2])(\/?|-|\.)(?:29|30)\2))(?:(?:1[6-9]|[2-9]\d)?\d{2})$|^(?:(?:0?2)(\/?|-|\.)(?:29)\3(?:(?:(?:1[6-9]|[2-9]\d)?(?:0[48]|[2468][048]|[13579][26])|(?:(?:16|[2468][048]|[3579][26])00))))$|^(?:(?:0?[1-9])|(?:1[0-2]))(\/?|-|\.)(?:0?[1-9]|1\d|2[0-8])\4(?:(?:1[6-9]|[2-9]\d)?\d{2})$", flags=re.MULTILINE)
test_str = ("\n"
"12/01/1986\n"
"02/29/2016\n"
"02/29/2015\n"
"13/31/1986\n"
"12/31/1980\n"
"1/32/2015\n"
"1/31/2015\n\n\n"
"01012016\n"
"01/01/2016\n"
"1/1/2016\n"
"1/1/16\n"
"01/01/16\n"
"01-01-2016\n"
"1-1-2016\n"
"1-1-16\n"
"01-01-16\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")