package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[\w\-][\w\-\.]+@[\w\-][\w\-\.]+[a-zA-Z]{1,4}`)
var str = `<a href="mailto:user@domain-1.com">user@domain-1.com</a>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}