re = /[\w\-][\w\-\.]+@[\w\-][\w\-\.]+[a-zA-Z]{1,4}/i
str = '<a href="mailto:user@domain-1.com">user@domain-1.com</a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end