$re = '/\b(?=\w*?-)[a-zA-Z0-9-]+(?= |$)/m';
$str = 'abcd def
ab-cd def i-have-slashes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);