re = /\b(?=\w*?-)[a-zA-Z0-9-]+(?= |$)/m
str = 'abcd def
ab-cd def i-have-slashes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end