$re = '/((?:[^,]*,[^,]*|[^,]+){1})(?:,|$)/';
$str = 'ABC1,ABCD2,A1,A234B456,C1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);