$re = '/(o(?>o(?>o(?>o(?>o(?>o(?>oo)?o)?o)?o)?o)?o)?o)/';
$str = 'oooooo';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);