using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cr((?!cr)[^.])*(?=\.[^.]+$)";
string input = @"cr US TRUMP DE NIRO 20161008cr_x080b.wmv
crcrUS TRUMP DE NIRO 20161008cr.xml";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}