package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)@[^\.|!|\s]{4,15}`)
var str = `@teststräng.
@teststräng!
@teststrängsadasdasdasdasddadasdasdas sadsadasdsadasd.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}