re = /@[^\.|!|\s]{4,15}/i
str = '@teststräng.
@teststräng!
@teststrängsadasdasdasdasddadasdasdas sadsadasdsadasd.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end