$re = '/@([\w\-]{4,})\b/iu';
$str = 'Nu testar vi att göra en quote från @fornamn.efternamn. Eller var den skriven från @test användare? Nu blev jag @osaker!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);