re = /@([\w\-]{4,})\b/i
str = 'Nu testar vi att göra en quote från @fornamn.efternamn. Eller var den skriven från @test användare? Nu blev jag @osaker!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end