#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=(\s|\b)user:)([a-zA-Z0-9_]*)\b"
Local $sString = "user:Lagoffre" & @CRLF & _
"users:[Lagoffre, Lagoffre]" & @CRLF & _
"" & @CRLF & _
"qlksjd user:Lagoffre| hfghgj" & @CRLF & _
"qksjdh users:[Lagoffre, Lagoffre]" & @CRLF & _
"" & @CRLF & _
"qsd wuser:Lagoffre" & @CRLF & _
"qsd wusers:[Lagoffre, Lagoffre]" & @CRLF & _
"" & @CRLF & _
"qsd user:Lagoffre jhb" & @CRLF & _
"qsd users:[Lagoffre, Lagoffre]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")