const regex = /(?<=(\s|\b)user:)([a-zA-Z0-9_]*)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(\\s|\\b)user:)([a-zA-Z0-9_]*)\\b', 'gm')
const str = `user:Lagoffre
users:[Lagoffre, Lagoffre]
qlksjd user:Lagoffre| hfghgj
qksjdh users:[Lagoffre, Lagoffre]
qsd wuser:Lagoffre
qsd wusers:[Lagoffre, Lagoffre]
qsd user:Lagoffre jhb
qsd users:[Lagoffre, Lagoffre]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}