package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)OnUploadCompleted\([0-9]+\s*,\s*\"\/(.+?)\"`)
var str = `<script type="text/javascript">
(function(){var d=document.domain;while (true){try{var A=window.parent.document.domain;break;}catch(e)
{};d=d.replace(/.*?(?:\.|$)/,'');if (d.length==0) break;try{document.domain=d;}catch (e){break;}}})();
window.parent.OnUploadCompleted(0,"/userfiles/abc.txt","abc.txt", "") ;</script>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}