re = /OnUploadCompleted\([0-9]+\s*,\s*\"\/(.+?)\"/m
str = '<script type="text/javascript">
(function(){var d=document.domain;while (true){try{var A=window.parent.document.domain;break;}catch(e)
{};d=d.replace(/.*?(?:\\.|$)/,\'\');if (d.length==0) break;try{document.domain=d;}catch (e){break;}}})();
window.parent.OnUploadCompleted(0,"/userfiles/abc.txt","abc.txt", "") ;</script>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end