import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[|,)\\s*'(.*?)'\\s*(?=\\]|,)";
final String string = "['Foo', 'Bar']\n"
+ "['F'oo', 'B'ar']\n"
+ "['F'oo', 'B'ar','Foo', 'Bar']\n"
+ "eq('Property', ['F'oo', 'Ba'r', '123'])";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}