re = /(?<=\[|,)\s*'(.*?)'\s*(?=\]|,)/m
str = '[\'Foo\', \'Bar\']
[\'F\'oo\', \'B\'ar\']
[\'F\'oo\', \'B\'ar\',\'Foo\', \'Bar\']
eq(\'Property\', [\'F\'oo\', \'Ba\'r\', \'123\'])'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end