re = /.*\b\K\d+\.\d+\.\d+\b/m
str = 'pip install package==
ERROR: Could not find a version that satisfies the requirement package== (from versions: 19.2.0, 19.5.0, 19.6.1, 19.7.0, 19.7.1, 19.8.0, 19.9.0)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end