$re = '/^(imp33|imp44)$/m';
$str = '#
javi_2223
javi55_555
imp33
imp44
javi32423
javi5646';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);