import re
regex = re.compile(r"^(imp33|imp44)$", flags=re.MULTILINE)
test_str = ("#\n\n"
"javi_2223\n"
"javi55_555\n"
"imp33\n"
"imp44\n"
"javi32423\n"
"javi5646")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")