#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^```\w+\n(.*?\n)+?```(?!`)"
Local $sString = "---" & @CRLF & _
"aliases: " & @CRLF & _
"created: 2023-06-01 16:05:51" & @CRLF & _
"grade: " & @CRLF & _
"keys: " & @CRLF & _
"modified: 2023-06-09 17:52:11" & @CRLF & _
"tags: " & @CRLF & _
"type: " & @CRLF & _
"---" & @CRLF & _
"# 设置波特率" & @CRLF & _
"" & @CRLF & _
"- 首先确定串口工作在什么模式, 因为不同的工作模式波特率的计算方式不一样, 这里拿 [[51单片机-串口通信相关的寄存器#工作方式 1 - 10 位异步收发器 (8 位数据) |串口工作方式 1]] 举例" & @CRLF & _
"" & @CRLF & _
"[串口工作方式 1的波特率计算](bookxnotepro://opennote/?nb={e2110889-ff80-422a-9be6-b93ea6c6a49f}&book=0b74da38c7c8b6eb08f99dbb49d646eb&page=194&x=66&y=387&id=7&uuid=0cca54394d67fa36000a6b0d501cd5b1) 我们最终设置的其实就是 TH1, 下面的 `定时器/计数器 1` 是一个东西" & @CRLF & _
"" & @CRLF & _
"![[Pasted image 20230601171852.png]] " & @CRLF & _
"" & @CRLF & _
"`STC90C51RC/RD+` 系列单片机的定时器有两种计数速率: 一种是 12T 模式, 每 12 个时钟加 1, 与传统 8051 单片机相同;另外一种是 6T 模式, 每 6 个时钟加 1, 速度是传统 8051 单片机的 2 倍, T0 的速率在烧录用户程序时在 STC-ISP 编程器中设置 " & @CRLF & _
"" & @CRLF & _
"- 我们设置单片机定时器工作在 12T 模式下, 那么公式就是 $2^{SMOD}/32*(定时器/计数器1的溢出率)$ " & @CRLF & _
"- [185](bookxnotepro://opennote/?nb={e2110889-ff80-422a-9be6-b93ea6c6a49f}&book=0b74da38c7c8b6eb08f99dbb49d646eb&page=184&x=35&y=306&id=2&uuid=da0e635b80714c7cbe1c9566f2115627) 当 SMOD=1 时, 则使串行通信方式 1, 2, 3 的波特率加倍, SMOD=0 时, 则各工作方式的波特率加倍(说的有点莫名其妙, 直接实验就行了) " & @CRLF & _
"- SYSclk 为系统时钟频率, 与用途有关, 比如说如果你要用到串口, 那么就常用 11.0592MHz 晶振 (设置串口波特率的时候误差是 0), 因为这个频率的晶振分频后可以得到精确的波特率, 如果要用到计时, 就常用 12MHz 晶振, 这样分频后是个整数, 计时更精确 ^axkydw" & @CRLF & _
"" & @CRLF & _
"# 示例程序" & @CRLF & _
"" & @CRLF & _
"## 串口的初始化步骤" & @CRLF & _
"" & @CRLF & _
"- 串口首先设置波特率, 波特率脉冲通过定时器产生, 所以第一步就是设置定时器确定波特率" & @CRLF & _
" 1. 确定 T1 定时器的工作方式 (TMOD 寄存器), 设置 [[MOC-51单片机-中断#定时器/计数器的 4 种工作方式|工作模式]]为 8 位自动重装模式" & @CRLF & _
" 2. 确定串口工作方式 (SCON 寄存器) " & @CRLF & _
" 3. 计算 T1 的初值 (设定波特率), 装载 TH1, TL1" & @CRLF & _
" 4. 启动 T1 (TCON 中的 TR1 位) " & @CRLF & _
" 5. 如果使用中断, 需要开启串口中断控制位 ( [[51 单片机中与中断相关的寄存器#中断使能控制寄存器 IE|IE 寄存器]]) " & @CRLF & _
"" & @CRLF & _
"````ad-code" & @CRLF & _
"title: 串口初始化, 设置串口工作方式, 根据需要的波特率设置定时器" & @CRLF & _
"```c" & @CRLF & _
"#define FOSC 11059200 // 单片机晶振频率" & @CRLF & _
"#define BAUD 9600 // 波特率设置为9600" & @CRLF & _
"" & @CRLF & _
"void uart_init(void)" & @CRLF & _
"{" & @CRLF & _
" SCON = 0x50; // 串口工作在模式1, 8位串口, 允许接收" & @CRLF & _
" PCON = 0x0; // 波特率不加倍" & @CRLF & _
"" & @CRLF & _
" // 通信波特率设置" & @CRLF & _
" TMOD = 0x20; // 设置定时器1为8位自动重装模式" & @CRLF & _
" TH1 = TL1 = 256 - FOSC / 32 / 12 / BAUD; // 定时器1赋初始值, 波特率不加倍的公式" & @CRLF & _
" // TH1 = TL1 = 256 - 2*FOSC / 32 / 12 / BAUD; // 波特率加倍的时候" & @CRLF & _
"" & @CRLF & _
" ET1 = 0; // 禁止定时器1中断" & @CRLF & _
" TR1 = 1; // 启动定时器1" & @CRLF & _
"" & @CRLF & _
" ES = 1; // 允许串口中断" & @CRLF & _
" EA = 1; // 开总中断" & @CRLF & _
"}" & @CRLF & _
"```" & @CRLF & _
"````" & @CRLF & _
"" & @CRLF & _
"## 串口发送数据" & @CRLF & _
"" & @CRLF & _
"````ad-code" & @CRLF & _
"title: 串口发送一个字节数据" & @CRLF & _
"```c" & @CRLF & _
"// 通过串口发送1个字节出去" & @CRLF & _
"void uart_send_byte(unsigned char c)" & @CRLF & _
"{" & @CRLF & _
" // 第1步, 发送一个字节" & @CRLF & _
" SBUF = c;" & @CRLF & _
"" & @CRLF & _
" // 第2步, 先确认串口发送部分没有在忙" & @CRLF & _
" while (!TI) ;" & @CRLF & _
"" & @CRLF & _
" // 第3步, 软件复位TI标志位" & @CRLF & _
" TI = 0;" & @CRLF & _
"}" & @CRLF & _
"```" & @CRLF & _
"````" & @CRLF & _
"" & @CRLF & _
"![[MOC-51单片机-中断#^9iots7]] " & @CRLF & _
"" & @CRLF & _
"````ad-code" & @CRLF & _
"title: 串口发送一个字符串(多字节), 需要使用到发送单字节函数" & @CRLF & _
"```c" & @CRLF & _
"void uart_send_string(unsigned char *str)" & @CRLF & _
"{" & @CRLF & _
" while (*str != '\0') " & @CRLF & _
" {" & @CRLF & _
" uart_send_byte(*str); // 发送1个字符" & @CRLF & _
" str++; // 指针指向下一个字符" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"```" & @CRLF & _
"````" & @CRLF & _
"" & @CRLF & _
"## 串口读取数据" & @CRLF & _
"" & @CRLF & _
"![[MOC-单片机-串口通信#串口发送时的软硬件协作方式]] " & @CRLF & _
"" & @CRLF & _
"````ad-code" & @CRLF & _
"title: 串口读取数据" & @CRLF & _
"```cpp" & @CRLF & _
"// brief: 通过串口读取一个字节" & @CRLF & _
"void UART_ISR() __interrupt(4)//串口中断函数" & @CRLF & _
"{" & @CRLF & _
" if(RI==1)//接收中断" & @CRLF & _
" {" & @CRLF & _
" RI=0;//软件清零, 一定要先清零再发送数据, 让单片机串口可以继续收数据, 若是先执行下面的命令, 然后RI=0, 会丢失一些数据, 因为在发送数据器件, 串口不会接收数据" & @CRLF & _
" uart_send_byte(SBUF) ;//把接收的数据发送到计算机" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"```" & @CRLF & _
"````" & @CRLF & _
"" & @CRLF & _
"![[MOC-51单片机-中断#^9iots7]] " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")