#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[pP]([a-zA-Z0-9 +-]|(%20)){13,}0000"
Local $sString = "PLX000000000PQ50000" & @CRLF & _
"pLX000000000PQ50000" & @CRLF & _
"plx000000000pq50000" & @CRLF & _
"PLX-0000-0000-0PQ5-0000" & @CRLF & _
"PLX-0000-0000-0PQ50000" & @CRLF & _
"PLX+0000+0000+0PQ5+0000" & @CRLF & _
"PLX%200000%200000%200PQ5%200000" & @CRLF & _
"PLX 0000 0000 0PQ5 0000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")