import re
regex = re.compile(r"[pP]([a-zA-Z0-9 +-]|(%20)){13,}0000")
test_str = ("PLX000000000PQ50000\n"
"pLX000000000PQ50000\n"
"plx000000000pq50000\n"
"PLX-0000-0000-0PQ5-0000\n"
"PLX-0000-0000-0PQ50000\n"
"PLX+0000+0000+0PQ5+0000\n"
"PLX%200000%200000%200PQ5%200000\n"
"PLX 0000 0000 0PQ5 0000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")