using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(categories )(^(?!.+(mandatory)))(mandatory)?";
string input = @"categories fruit meat mandatory";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}