re = /(categories )(^(?!.+(mandatory)))(mandatory)?/i
str = 'categories fruit meat mandatory'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end