import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h2\\s*>\\s*([\\S\\s]*?)\\s*</h2\\s*>\\s*([\\S\\s]*?)(?=\\s*<h2\\s*>|\\s*$)";
final String string = "<h2>heading one</h2>\n"
+ "<p>different content in here <a>test</a> <b>test</b></p>\n"
+ "<p>different content in here <a>test</a> <b>test</b></p>\n\n"
+ "<h2>heading two</h2>\n"
+ "<p>different content in here <a>test</a> <b>test</b></p>\n\n"
+ "<h2>heading three</h2>\n"
+ "<p>different content in here <a>test</a> <b>test</b></p>\n"
+ "<p>different content in here <a>test</a> <b>test</b></p>\n"
+ "<p>different content in here <a>test</a> <b>test</b></p> \n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}