import re
regex = re.compile(r"<h2\s*>\s*([\S\s]*?)\s*</h2\s*>\s*([\S\s]*?)(?=\s*<h2\s*>|\s*$)")
test_str = ("<h2>heading one</h2>\n"
"<p>different content in here <a>test</a> <b>test</b></p>\n"
"<p>different content in here <a>test</a> <b>test</b></p>\n\n"
"<h2>heading two</h2>\n"
"<p>different content in here <a>test</a> <b>test</b></p>\n\n"
"<h2>heading three</h2>\n"
"<p>different content in here <a>test</a> <b>test</b></p>\n"
"<p>different content in here <a>test</a> <b>test</b></p>\n"
"<p>different content in here <a>test</a> <b>test</b></p> \n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")