using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(?=\<\?php echo)|(?<=\?\>)(.*)";
string input = @"customFields[<?php echo $field[""id""]; ?>][type]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}