re = /(.*)(?=\<\?php echo)|(?<=\?\>)(.*)/
str = 'customFields[<?php echo $field["id"]; ?>][type]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end