package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,`)
var str = `first (1,2),second (child (nested), child2), third`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}