$re = '/(\((?:[^()]++|(?1))*\))(*SKIP)(*F)|,/m';
$str = 'first (1,2),second (child (nested), child2), third';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);