#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(\d+) (?:(?:<(CARRE|RECTANGLE|OVALE|LIGNE)> (\d+) (\d+) (\d+) (\d+) </(?:CARRE|RECTANGLE|OVALE|LIGNE)>)|<(CERCLE)> (\d+) (\d+) (\d+) </CERCLE>)$"
Local $sString = "1111 <CARRE> 123 321 111 222 </CARRE>" & @CRLF & _
"2222 <RECTANGLE> 234 432 333 444 </RECTANGLE>" & @CRLF & _
"3333 <CERCLE> 345 543 555 </CERCLE>" & @CRLF & _
"4444 <OVALE> 456 654 666 777 </OVALE>" & @CRLF & _
"5555 <LIGNE> 567 765 888 999 </LIGNE>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")