import Foundation
let pattern = #"^(\d+) (?:(?:<(CARRE|RECTANGLE|OVALE|LIGNE)> (\d+) (\d+) (\d+) (\d+) </(?:CARRE|RECTANGLE|OVALE|LIGNE)>)|<(CERCLE)> (\d+) (\d+) (\d+) </CERCLE>)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1111 <CARRE> 123 321 111 222 </CARRE>
2222 <RECTANGLE> 234 432 333 444 </RECTANGLE>
3333 <CERCLE> 345 543 555 </CERCLE>
4444 <OVALE> 456 654 666 777 </OVALE>
5555 <LIGNE> 567 765 888 999 </LIGNE>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)