package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^(]*\(|\*.*`)
var str = `1.2.3 (1.234*xY)`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}