$re = '/[^(]*\(|\*.*/m';
$str = '1.2.3 (1.234*xY)';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;