const regex = /(?<=((birds?)|(pigs?)).*)\b[a-z]{3,}\b(?=.*((birds?)|(pigs?)))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=((birds?)|(pigs?)).*)\\b[a-z]{3,}\\b(?=.*((birds?)|(pigs?)))', 'gmi')
const str = `Pigs are farm animals. Birds are not
My bird fly in his cage. My pig run in the garden.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}