re = /(?<=((birds?)|(pigs?)).*)\b[a-z]{3,}\b(?=.*((birds?)|(pigs?)))/mi
str = 'Pigs are farm animals. Birds are not
My bird fly in his cage. My pig run in the garden.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end